FlowHeater - The Data Import / Export Specialist
See also the existing examples of using the Access Adapter , which may answer your question: CSV import , generate test data , automated batch CSV import

Newbie Help Please - Access DB to CSV output issue

  • Ken Starnes
  • Topic Author
  • Offline
  • New Member
  • New Member
More
6 years 1 week ago - 6 years 1 week ago #3010 by Ken Starnes
Access mdb (?97 version) to csv output conversion is generating an extra field after Staff_id (see attachment) and I can't see any reason why
I've removed any filters I had thinking they were messing it up.

I also need to select items greater than 10 in the Job Field and drop the rest.

Can supply the .FHD file if required but I don't like to send company confidential data (unless I can edit some of it out)
Thanks
Ken
Attachments:
Last edit: 6 years 1 week ago by Ken Starnes.

Please Log in or Create an account to join the conversation.

  • Ken Starnes
  • Topic Author
  • Offline
  • New Member
  • New Member
More
6 years 1 week ago - 6 years 1 week ago #3011 by Ken Starnes
Replied by Ken Starnes on topic Newbie Help Please - Access DB to CSV output issue
when I changed the input type to string (on the left hand side) the output is formatted correctly.
Doesn't seem logical to me.

I also can't get the filter/if then else to work - how do I get Flowheater to drop those records less than 10
Last edit: 6 years 1 week ago by Ken Starnes.

Please Log in or Create an account to join the conversation.

More
6 years 1 week ago - 6 years 1 week ago #3012 by FlowHeater-Team
Replied by FlowHeater-Team on topic Newbie Help Please - Access DB to CSV output issue
Hi Ken,

I suppose you´re using quotation marks and in the TextFile Adapter on the WRITE side you´ve configured that quotations marks should only be used for data type STRING?

In case when your number format are with an comma as group delimiter and your CSV delimiter are also comma you get this result.
For example your staff_id is greater than 1000, the number are outputed as 1,000 (including comma). In this case the output are not quoted and you see in your output an additionl column.

To solve this issue it should be enough the disable the quotation mark option “Only apply to STRING data types” in the TextFile Adapter on the Delimiter tab, see screenshot below.




To filter records you have to use the Filter Heater in combination with an IF-THEN-ELSE Heater for the filter condition. In the condition you have to change the compare data type to INTEGER and set to condition to the desired one. For example < 1000 that’s all. I´ve made a short example to demonstrate this. In this example I included also the quotation mark issue.


Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.
Attachments:
Last edit: 6 years 1 week ago by FlowHeater-Team.

Please Log in or Create an account to join the conversation.

  • Ken Starnes
  • Topic Author
  • Offline
  • New Member
  • New Member
More
6 years 1 week ago - 6 years 1 week ago #3015 by Ken Starnes
Replied by Ken Starnes on topic Newbie Help Please - Access DB to CSV output issue
Thanks for the help - it makes more sense now. Some of my issues were with commas in the original data which I have now stripped out using the find/replace heater option. No doubt I will be back with other questions. I'm only creating CSV data with commas as separators which I then modify using a rexx batch command to reformat to our accounts package requirements
Last edit: 6 years 1 week ago by Ken Starnes.

Please Log in or Create an account to join the conversation.

Time to create page: 0.348 seconds

other Languages

de

FlowHeater Home

de en

Imprint/Contact

Privacy Statement

Copyright © 2009-2023 by FlowHeater GmbH.
All rights reserved.

Follow us on

twitter  facebook

YouTube

 de en