Dynamic data import / export

datenbank

simply more productive
Up to 100,000 records can be processed with the freeware version!
Welcome, Guest
Username: Password: Remember me
Welcome to the FlowHeater support forum.

Questions about using FlowHeater are answered here.
  • Page:
  • 1

TOPIC: Automated XML to MySQL import restriced to 50 rows

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3307

  • FlowHeater-Team
  • FlowHeater-Team's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
  • Posts: 275
Dear Sir, Madam,

We have been a customer of your excellent flowheater for some time now. We use your software to move data from one database (SOAP) to another ( MYSQL ).

We used to do this manually with flowheater designer every week. However I wanted it to be automated. I wrote a little software program to extract a XML file from the SOAP database.

Now I would like to import the XML file into the MYSQL database with the same little software program (due to a command prompt action).

We bought a new license this week for all the extra possibilities with the XML files. When we use the FHBatch manually in the command prompt it works like it should.

However when we use the software (web application hosted by TOMCAT), it will only import 50 rows. Normally we have about 150 rows.

Do you have any idea what is wrong? When we start FlowHeater Designer it says the software is correctly licensed.

Kind regards,
Pieter
Request received by Email

Please Log in or Create an account to join the conversation.

Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.
Last Edit: by FlowHeater-Team.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3308

  • FlowHeater-Team
  • FlowHeater-Team's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
  • Posts: 275
Hi Pieter,

The reason why is that the activation for single licenses only activate the software for the current user.

In your case I guess that your Tomcat service runs unter another “technical” user account? In this case you just have to login one time with this technical user account and activate the software again and your automated XML to MySQL batch import should work.

Please Log in or Create an account to join the conversation.

Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3310

  • Pieter Heesterbeek
  • Pieter Heesterbeek's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
Thanks for the reply. I have changed the user of the tomcat service to the current user.
But it does not make any difference. I also tried a completely different user for tomcat and activated flowheater for that user.
Also no luck.

Please help.

Please Log in or Create an account to join the conversation.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3316

  • FlowHeater-Team
  • FlowHeater-Team's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
  • Posts: 275
Hi Pieter

Please try to execute the attached Definition under the TOMCAT service user account by FHBatch . The Definition creates just a short text file “env.txt” with your envirnonment settings. I need this for a deeper look inside, Thanks.

File Attachment:

File Name: envirnonment.zip
File Size: 2 KB
Attachments:

Please Log in or Create an account to join the conversation.

Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3317

  • Pieter Heesterbeek
  • Pieter Heesterbeek's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
Herewith my env.txt
Attachments:

Please Log in or Create an account to join the conversation.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3318

  • Pieter Heesterbeek
  • Pieter Heesterbeek's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
I think the java is executed in some sort of extra environment? See pictures.
I tried using the command: runas. But that didn't work either.
Attachments:

Please Log in or Create an account to join the conversation.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3321

  • FlowHeater-Team
  • FlowHeater-Team's Avatar Topic Author
  • Offline
  • Administrator
  • Administrator
  • Posts: 275
Hi Pieter

The envirnonement output looks fine, FlowHeater ist correctly activated for user admin. Are you sure that this defintion has been started from your TOMCAT application and the TOMCAT service starts under this user account?

Please add the /LOGFILE option to the call of the Batch module . For example. FHBatch.exe /LogFile C:\Temp\fhbatch.log your-import-definition.fhd

All outputs from FHBatch.exe are now also in the logfile, please post this log file for further inverstigations.

Please Log in or Create an account to join the conversation.

Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.

Automated XML to MySQL import restriced to 50 rows 2 months 2 weeks ago #3324

  • Pieter Heesterbeek
  • Pieter Heesterbeek's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
I fixed it. As you can see in the picture of my previous post, Windows opened a "interactive service detection" windows when I tried to use the command: runas.
Runas gave an error and the window kept open. In that window I started flowheater and I could activate the license.

Now it works.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: FlowHeater-Team
Time to create page: 0.118 seconds