Dynamic data import / export

datenbank

simply more productive
Up to 10,000 records can be processed with the freeware version!
Welcome, Guest
Username: Password: Remember me
Welcome to the FlowHeater support forum.

Questions about using FlowHeater are answered here.

TOPIC: FHDesigner fast but FHBatch slow

FHDesigner fast but FHBatch slow 1 year 7 months ago #2368

  • Andrew Wojciak
  • Andrew Wojciak's Avatar
  • Offline
  • Junior Member
  • Posts: 21
I have built a definition (.fhd) to simply filter records by date range, from 18MBsize.txt file to ~4MBsize.txt file. When I run this definition in FHDesigner it takes just 30 sec but via FHBatch it run over 1/2 hr and more (I had to stop as I cannot accept more than 5 minutes anyway). I have to use FHBatch to automate and schedule runs nightly. I am using Task Scheduler to run FHBatch.
Any suggestions why is taking so long via FHBatch?
Andrew W.
The administrator has disabled public write access.

FHDesigner fast but FHBatch slow 1 year 7 months ago #2369

  • FlowHeater-Team
  • FlowHeater-Team's Avatar
  • Offline
  • Administrator
  • Posts: 239
Hi Andrew,

Is the FHBatch job always slow or just when running as scheduled windows task? Have you tried to run the .FHD Definition manually via the Batch Module in the Command (CMD) window?

I guess just the first one is slow. In this case please be sure that you run the scheduled task with the same user rights.
Best wishes
Robert Stark

Did this answer your question? We would be grateful if you provide a brief comment as feedback. It may also help others who may have encountered a similar problem.
The administrator has disabled public write access.

FHDesigner fast but FHBatch slow 1 year 7 months ago #2370

  • Andrew Wojciak
  • Andrew Wojciak's Avatar
  • Offline
  • Junior Member
  • Posts: 21
Thank you, Robert. Issue has been resolved. As you suggested it was a system login/security related issue. I had to use the same log in for FHDefinition, FHDesigner, FHBatch, and TaskScheduler.
Last Edit: 1 year 7 months ago by Andrew Wojciak. Reason: correction
The administrator has disabled public write access.
Moderators: FlowHeater-Team
Time to create page: 0.071 seconds