Dynamischer Daten Import / Export

datenbank

weil Einfach - produktiver ist
Mit der Freeware Version können bis zu 10.000 Datensätze verarbeitet werden!
Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
Willkommen im FlowHeater Support Forum!

Hier werden Fragen zum Umgang mit dem FlowHeater beantwortet.

THEMA: fehler im Batch / irgendwie komisch

fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1102

  • Sven
  • Svens Avatar
  • Offline
  • Senior Member
  • Beiträge: 45
Moin,

ich bekomme folgenden Fehler vom Batchprozess gemeldet:
Start: 25.10.12 06:15:26
Conversion failed when converting the nvarchar value '?' to data type int.
Wenn ich dann das entsprechende Modell im Flowheater öffne und ausführe ist alles in Ordnung.

Read:SQL Server Write: TextFileAdapter

Das passiert öfter, führe ich das Model von Hand aus,läuft es für eine gewisse Zeit auch im Batch problemlos....aber es kommt wieder.

Gerade sehe ich es, aus einem anderen Modul kommt im Batch der gleiche Fehler wieder:
Start: 25.10.12 06:25:18
Conversion failed when converting the nvarchar value '?' to data type int.

Jetzt gerade das Model manuell ausführt, und alles ok!



Irgendwie komisch:
Ich habe auch seit einiger Zeit(ich weiss nicht ab welcher Version) oft das Gefühl, das sich Einstellungen im Model irgendwie verändern. Ich kann es noch nicht konkret festmachen, da ich die Einstellung vornehme und dann "vergesse". Ich stelle ein Zielfeld auf String und bekomme später aus dem Batchprozess Fehler gemeldet die eigentlich nicht sein können...z.B. es wird eben jenes Feld vom Batch angezeigt, weil es angeblich ein Integer Feld ist. Mache ich das Model auf, steht die Einstellung auf Integer. Wie gesagt, bislang konnte ich nicht das Gegenteil "beweisen". Aber in einigen Fällen könnte ich schwören, die Einstellungen entsprechend vorgenommen zu haben. Diese Fälle häufen sich....der Grund dafür ist mir schleierhaft.


Ansonsten:
Ist der Flowheater in meiner täglich Arbeit nicht mehr wegzudenken! Er ist eine Offenbarung! Ich habe bereits zig Modelle gebastelt und setze Ihn großflächig ein. Meine ausländischen Partner kommen oft aus dem Staunen nicht raus, das es sowas Einfaches gibt!
Verbesserungen:
Wären für mich im Debugging und bei den Fehlermeldungen wünschenswert. Ich hoffe zudem, das mein Wunsch, aus Sourcetabellen , Zieltabellen generieren zu können eines Tages Wirklichkeit wird. ;-)




Viele Grüße
Sven
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1103

  • FlowHeater-Team
  • FlowHeater-Teams Avatar
  • Offline
  • Administrator
  • Beiträge: 1101
Hallo Sven,

ich will jetzt nicht generell einen Fehler ausschließen aber hier vorab eine Anmerkung.

Wenn eine Definition ausgeführt wird, wird das über den Designer sowie über das Batch Modul auf die komplett identische Art und Weise durchgeführt, hier gibt es keinen Unterschied. Der Komplette Code der dafür notwendig ist liegt in der FlowHeater.Core.dll diese wird sowohl vom Designer sowie vom Batchmodul verwendet.


Zu deinem Problem habe ich eigentlich nur eine Erklärung. Versuchst du evtl. eine FlowHeater Definition >= Version 2.3.0 mit einer kleineren FHBatch Version laufen zu lassen? Mit Version 2.3.0 wurde ein neuer Datentyp DOUBLE eingeführt und dies führt bei Ausführung mit früheren Versionen zu Problemen dieser Art. Ab Version 2.4.1 wird das mit früheren Versionen besser geprüft.

Bitte prüfe mal ob deine FHBatch Version die gleiche wie die des Designers ist.

Sollte dass das Problem nicht lösen würde ich vorschlagen du kopierst Dir lauffähige Definitionen, die kopierte Definition bitte nicht mehr mit FlowHeater öffnen/verwenden. Tritt das Problem wieder auf vergleichst du die zwei Definitionen über einen Texteditor (oder WinMerge) miteinander. So finden wir schnell heraus wo das eigentliche Problem liegt.


Zu deinem Wunsch) Mit dem seit Version 2.5.0 verfügbaren SQLite Adapter wurde diese Funktionalität bereits eingeführt, für die anderen Datenbank Adapter wird das Anfang nächsten Jahres verfügbar sein :-)
gruß
Robert Stark

Wurde Ihre Frage damit beantwortet? Bitte geben Sie ein kurzes Feedback, Sie helfen damit auch anderen die evtl. ein ähnliches Problem haben. Danke.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1104

  • Sven
  • Svens Avatar
  • Offline
  • Senior Member
  • Beiträge: 45
Moin Robert,
obwohl ich immer das komplette Verzeichnis lösche, bevor ich die neuen Flowheater Dateien dort reinkopiere, habe ich nochmal nachgeschaut. Alles ok! Aber der Effekt ist definitiv da.

Heute Morgen habe ich den gleichen Fehler wieder.
Start: 26.10.12 06:15:23
Conversion failed when converting the nvarchar value '?' to data type int.

Eben habe ich das erste Mal das Model manuell ausgeführt.

Schau dir das Video an. Es handelt sich natürlich um das gleiche Model!

Anhang flowheater.zip nicht gefunden

Anhang:
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1105

  • Sven
  • Svens Avatar
  • Offline
  • Senior Member
  • Beiträge: 45
Auch die zweite Definition von gestern ist auf die Bretter gegangen....mit den gleichen Effekt!
Oft läuft aber wie gesagt danach(nach dem manuellen Lauf) erstmal alles wieder normal. Das kann allerdings auch Zufall sein!


Mein Wunsch:
Das ist ja eine suuuuuper Nachricht! Vielen Dank Robert!!
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1106

  • FlowHeater-Team
  • FlowHeater-Teams Avatar
  • Offline
  • Administrator
  • Beiträge: 1101
Hallo Sven,

bin leider erst jetzt darauf gekommen, aber die Meldung wird eigentlich vom MS SQL Server während der Abfrage der Daten generiert und nicht vom FlowHeater!

Du scheinst im Abfrage Select einen CAST eines NVARCHAR Feldes nach INT zu machen und im Datenbankfeld stehen keine nummerischen Werte.

Das erklärt jetzt zwar noch nicht warum dass über den Designer immer (evtl. zufällig) läuft?

Hinweis: Den CAST könntest du Dir sparen, du kannst das auch über den FlowHeater konvertieren. Hier werden dann Warnungen ausgegeben, dass der Wert "[keine Zahl]" nicht in den FlowHeater Datentyp INTEGER umgewandelt werden konnte.

Zur weiteren Analyse bräuchte ich mal eine betroffene FlowHeater Definition. Werden die Daten über eine Abfrage (View) selektiert bräuchte ich das zughörige SQL Select Statement. Gerne auch per Email.
gruß
Robert Stark

Wurde Ihre Frage damit beantwortet? Bitte geben Sie ein kurzes Feedback, Sie helfen damit auch anderen die evtl. ein ähnliches Problem haben. Danke.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1107

  • Sven
  • Svens Avatar
  • Offline
  • Senior Member
  • Beiträge: 45
Hallo Robert,
das ist ja gerade mein Problem, da ist kein Fragezeichen!
Den SQL kann ich ja auch direkt ausführen! Die Sourcetabelle habe ich natürlich überprüft....da ist kein "?"! Und ja, es ist ein View. Die Definition lässt sich manuell problemlos ausführen(kann man im Video ja sehen).

Vielleicht ist das Modell irgendwie "kaputt"....Ich werde es einfach nochmal neu anlegen.

Melde mich später nochmal.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1108

  • FlowHeater-Team
  • FlowHeater-Teams Avatar
  • Offline
  • Administrator
  • Beiträge: 1101
Hallo Sven,

evtl. liegt es daran, dass du mit unterschiedlichen Benutzern und unterschiedlichen SQL Server Benutzerprofilen (deutsch/englisch) arbeitest?

Bitte prüfe mit welchen Dezimaltrennzeichen Zahlen im deinem VARCHAR Feld gespeichert werden. Wenn hier teilweise Zahlen mit Nachkommastellen vorhanden sind und diese dann durch ein falsches Profil zufällig das falsche Dezimaltrennzeichen haben würde dass das verhalten evtl. erklären.
gruß
Robert Stark

Wurde Ihre Frage damit beantwortet? Bitte geben Sie ein kurzes Feedback, Sie helfen damit auch anderen die evtl. ein ähnliches Problem haben. Danke.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Aw: fehler im Batch / irgendwie komisch 4 Jahre 1 Monat her #1116

  • Sven
  • Svens Avatar
  • Offline
  • Senior Member
  • Beiträge: 45
Moin Robert,

nach Neuanlage des Models funktioniert alles wieder wie gewohnt. Ich habe keine Ahnung was das Problem ist. Das Model ist sehr simple. Jetzt funktioniert es seit einigen Tagen aber wieder offensichtlich zuverlässig.

Vielen Dank!
Sven
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: FlowHeater-Team
Ladezeit der Seite: 0.087 Sekunden